The MotionMonitor xGen Hardware Guide:
The MotionMonitor xGen Interface to Polhemus Viper Hardware

Overview

e This guide outlines the steps required to configure and collect from Polhemus Viper
devices that are connected to The MotionMonitor xGen. If using other Polhemus
devices such as the Liberty, Patriot, G4, or Fastrak, please see their respective
guides.

e This document is divided into 4 sections:

Configuring Polhemus Viper Hardware in Viper Command Manager
Configuring Polhemus Viper Hardware in The MotionMonitor xGen
Calibrating a Stylus

Defining Biomechanical Model within The MotionMonitor xGen

PwnNE

Assumptions

e The Polhemus Viper device is connected to The MotionMonitor xGen computer via
USB.

e The Polhemus drivers and Polhemus Viper Command manager host software are
installed using the installation CD and instructions provided by Polhemus.
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Section 1: Configure Polhemus Viper Hardware in the Viper Command Manager

1. Ensure that the VPcmdMgr software is installed on the computer which the Viper
device is connected to. Contact your Client Support Engineer if you require this
installer.

VPcmdMgr

2. Open Sensor Settings Options:

o Within the command manager, select the “Continuous mode” stream icon
(|E|) to stream and visualize sensor data as a plane.

o Click the “Edit Tracker Configuration” icon () to bring up the settings
options for the sensors.
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3. Click on the “All Sensor Settings” icon (El) to bring up the Sensor Block
Configuration menu.
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4. Configure Viper Settings (Before Collecting Data in The MotionMonitor xGen):

o For a full description of this menu, please see the Viper User Manual.
o Source Select
e |f multiple sources are used, override the default Source Selection
settings.
o Hemisphere Tracking
e Enable Hemisphere Tracking for tracking coverage around all sides
of the source/sources.
o Filters and Prediction Filters (Optional)
e Enable or Disable Prediction Filters for Position and Orientation
readings
e Specify the filter settings under Filters

5. Save Viper Sensor Settings:

o Click the Apply Changes () to save the settings for these menus. The
settings will be applied to any sensor with a check box next to it in the Status
pane.
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6. If using multiple source configurations, define the position and orientation of the

transmitters in the SEU Block Configuration menu (). For a full description of this
menu, please see the Viper User Manual.

o For the Output Units section, the Position Units must be set to “CM” and the
Orientation Units must be set to “QUATERNION".
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7. Save Viper Configuration Settings Before Exiting the Viper Command Manager:

o Go to Device > Persist Current Configuration

o This will prevent the settings from being overwritten when the console is
power cycled.

o When prompted to confirm Persist Current Configuration to Viper Flash
Memory, click Yes.
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Section 2: Configure Polhemus Viper Hardware in The MotionMonitor xGen

1. Add Polhemus Device in The MotionMonitor xGen:

o Go to Components window > Setup Tab > Hardware.

o Inthe hardware node, add the Polhemus device from the Add button in the
parameters panel at the bottom of the Components window or by right-clicking
the Hardware node and adding the device through the cascading drop list.

Components u
& Setup Analysis
,i World Axes )
4 Hardware & Add » }
@ Subjects -
| \@n Ohiacte 2

Live period: ‘10

Playback step interval:

‘ sec

Use formula ~  |.01

‘ sec

£ Polhemus v

&) Add

Page Last Updated On: 10/17/2025

The MotionMonitor Support Center

Contact Us



https://themotionmonitor.com/support/
mailto:Support@TheMotionMonitor.com?subject=Knowledge%20Base%20Article%20Questions

2. Configure Polhemus Device Parameters:

o Click on the Polhemus device to bring up the Polhemus parameters panel.

o Specify:
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Name (optional)

Measurement rate (choose from supported measurement rates
for the device)

Synchronizing event (Optional)

e A Boolean event can be specified for performing an active
alignment of the Polhemus data stream with synchronous
events from other hardware data streams. The
Synchronizing event here must be defined from the
Polhemus data (i.e. the stylus pen button or event marker,
which could be defined as Polhemus1.Sensorl.Event==1,
for instance, if the synchronizing event were connected to
the first sensor).

Hardware type (Viper)

Stylus to use (This stylus will be used for aligning this hardware
device i.e. digitizing new world axes unique from the default
transmitter coordinate system.)

Suspend live data (Optional)

e The processing and display of data in a live mode uses
computer resources, so this option allows the user to
optimize computer resources and free up more processing
power for data collection. This setting is independent for
each hardware device and once an activity has been
recorded data from the full measurement rate will be
accessible for analysis.
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Components n

#F setup n Analysis

J-., World Axes ~
v it Hardware

» & Polhemusl

a Subjects

% Objects

Polhemus name: |Polhemu51

Measurement rate: | 120Hz

[ synchronizing event: when | Uss drop-ists | | <noselection> | becomes true

W Setup
Hardware type: Viper w

Stylus to use: | <none> | MNOTE: Stylus rigid body must be a Polhemus sensor

Distortion correction in use: None

: : Correct Distortion. ..

W Advanced

[ suspend live data {reduces CPU requirements by making data only available in post-processing)

(9 Activate : : Align... : : Align to Other Hardware. ..
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3. Position Transmitter and Sensors:

o If enabled in the Viper Command Manager, data from the sensors can be
taken from any side of the transmitter, but the sensors must be in the
positive X hemisphere when the device is Powered on and activated. (See
the default transmitter reference frame depicted below.)

o The Polhemus Viper Device also supports the use of multiple transmitters.
However, the settings for each system must be configured prior to activating
hardware in The MotionMonitor xGen. These settings are configured in the
Viper command manager (see Section 1)
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4. Activate the Device:

o Click Activate to initialize communication between The MotionMonitor xGen and
Polhemus hardware.
o Optional Advanced Features:

e Click Align to digitize a new world axes layout according to selections for
the World Axes layout in the World Axes Setup Component. Align is used
for hybrid configurations.

e Click Correct Distortion to perform metal mappings.

e Please contact your Client Support Engineer for more information
regarding these advanced processes.

5. Verify Device Activation and Apply Filters:

o After successfully activating the Polhemus Device, the activated sensors will

populate under the Polhemus Hardware node
e Expand the Polhemus Hardware node to show the activated sensors.

o Selecting a Sensor brings up the Sensor parameters panel.

o Before data collection, you can enable Polhemus Fly True Technology (FTT)
Mode. This feature allows for real time distortion mitigation during data
collection. Only Viper FT sensors support FTT Mode.

e The sensor LED on the electronics unit will turn Blue with the FTT is
engaged.
e There are two settings for the FTT:
= Stationary Source Mode — Sources are mounted in a fixed
position
= Moving Source Mode — Sources may be used in dynamic
conditions
e Please refer to the Viper User Manual or contact your Client Support
Engineer for more information on using the FTT Mode.

o Apply Data Repair and Filter Settings (Optional)

e These settings can be enabled or disabled here, pre or post data
collection.
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6. At this point, data available directly from the Polhemus hardware can be displayed in

Components

# setup “ Analysis

- World Axes
v 4+ Hardware
v # Polhemusl
4 Sensor
& Subjects

FTT mede: | Stationary Source Mode

[ repair:

Max interval: |1

[ Butterworth filter:  Freq: 20

[ chebyshev filter:  Freq: 20

[ FFT lowpass filter:  Freq: 20 Rolloff; 2
[] FFT highpass filter:  Freq: o Rolloff: |2
\as! Add Notch Filter Apply to All

graphs or used in custom equations, as depicted below.
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Section 3: Configure Stylus

1. Add a Stylus:

o A Stylus will need to be configured for digitizing the alignment of the Polhemus
hardware device, force plates, and defining joint centers or other landmarks of

interest for your subject.
o Go to Components Window > Setup Tab > Hardware

o Add the Stylus device from the Add button in the parameters panel at the
bottom of the Components window or by right-clicking the Hardware node and

adding the device through the cascading drop list.
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2. Configure Stylus:
o Click on the Stylus device to bring up the Stylus parameters panel.
o Specify:

Name (Optional)
Rigid body sensor attached to the stylus
An Is-button-pressed expression (Optional)
o Boolean value that allows for an external trigger to be used in the
OK messages where the stylus is being used in the setup, such as
when performing the alignment of a hardware device, aligning
force plates or when digitizing a subject.
Check Rigid body is at stylus tip (If applicable)
o Can be enabled when the origin of the Rigid body specified for the
stylus is already located at the tip for the stylus being used, as in
the example of Polhemus Stylus Pens.

o Click Calibrate to set Stylus tip position and orientation.

The Calibrate button walks through the procedure of calculating the
vector offset from the Rigid body origin to the stylus tip or captures the
orientation of the stylus if the “Rigid Body is at stylus tip” is selected.

A tutorial video for configuring and calibrating a stylus can be found at
https://themotionmonitor.com/support/.

Components n
# Setup [ Analysis
A, World Axes Al
|
v 4t Hardware |
./ Stylus1 I

Stylus name: |Stylus1 |
Rigid body: |Use drop-ists v | | <no selection> v
Is-button-pressed expression: |Use drop-i ~ | <no selection> v
[ Rigid body is at stylus tip

A Calbrate...
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Section 4: Define Biomechanical Model within The MotionMonitor xGen

1. Set Up Subject:
o Right-click on the Subjects header within the Components Setup tab and add a
new subject.
o Assign a name (Optional) and enter basic anthropometric data.
o Confirm subject orientation for Neutral Stance and Stylus to use for digitizing.

Components n

#F Setup Analysis

v @ Subjects ~
v @ Subject!

Segments
I Joints
# Muscles
@ Objects
v X Permanent Variables
X SacrumSensor
X RThighSensor
X _LThighSensor |

Subject name: |Subjectl

Neutral stance: |Arms down, thumbs forward v

[[] Assume neutral stance while supine

Body mass: Use formula v |75 ‘kg

Body height: 'Use formula v i1.75 ‘m

Assume rigid bodies to be orientation-only
Static fixation joint: T12/L1
Stylus to use: | <none>

[] Enable muscle modeling

Maximum foot-to-GRF distance: |50 cm

] use spline fit to forces and moments

Spline interval: |10 msec

A Calibrate... |~/ Anthropometrics... Import Muscle Model.. Export Muscle Model... | # Map Muscles... % Track
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2. Set Up Subject Segments:

o Under the Subject > Segments, enable desired body segments to be tracked and
assign rigid bodies to those segments. Additional basic anthropometric
information can be defined here for each segment as well.

Components n

& Setup Analysis

2 Thorax Al
v a Subjects
v @ Subject!
v/ Segments
Head
/" Thorax
Lumbar

alajoly

Sacrum 5

Rigid body: |Use existing v

Existing rigid body: |Use drop-lists v | RigidBodyCollectionl » |Thorax v | |Axes v
Longitudinal axis: 'Positive X-axis
Anterior axis:  Positive Z-axis v

Origin: |Proximal joint v

Segment-mass-to-body-mass ratio: ‘0.216

COM-offset-to-segment-length ratio: |0.82

Transverse-ROG-to-segment-length ratio: ‘ 0.3199

|
|
Longitudinal-ROG-to-segment-length ratio: l0.465 ‘
|

Anterior-ROG-to-segment-length ratio: ‘ 0.505

3. Define each segment’s proximal and distal joint centers:

o The required joint centers will be automatically populated, under Subject >
Joints, based on the selection of segments.

o Joint centers can be defined via digitizing, marker-based expressions, linear
regression, or functional (rotational) methods.

Components H
& Setup Analysis

Segments )
v ;‘ Joints
#am
# T2
o 15/51
& Left Hip
# Right Hip
;‘ Left Knee
r 4 Right Knee
# Muscles
& Objects
v X Permanent Variables
X SacrumSensor
X RThighSensor
X _LThighSensor R

ISe expression

: U ]
Position: | Use forf] pigitize with stylus |

Use functional method
Forward offset: |0/\;ca pavis formula ‘ L
| Use Bell formula
Leftward offset: l,c Use Davis formula with stylus ‘ cm
Upward offset: ‘u Use Bell formula with stylus ‘ an

Page Last Updated On: 10/17/2025

The MotionMonitor Support Center | Contact Us



https://themotionmonitor.com/support/
mailto:Support@TheMotionMonitor.com?subject=Knowledge%20Base%20Article%20Questions

4. Calibrate Subject:

o Once the Subject Segments and Joints definitions are completed, click the
Subject Calibrate button to complete the model setup following the on-screen
prompts. A warning message will be displayed for any definitions that have not
been appropriately defined.

b

Optionally, add anatomically based local coordinate systems to segments via adding an
Axis System. Define axes based on sensor and landmark positions.

o Select the Rigid Body axes tracking the segment and general axes layout.
o Define points for the proximal and distal endpoints of the primary axis, a point

along the secondary axis and a point for the Origin.

o The default local coordinate axes generated by The MotionMonitor xGen are
defined as having a long axes through the joint centers and A/P and M/L axes
being orthogonal to the long axes and parallel to the world when the subject was
standing in the neutral position.

6. The subject model is now ready for data collection and computations.

Components

#F Setup @ Analysis

O Head
v /" Thorax
¥ Landmarks

v /‘ Axis Systems
v 2 AxisSystem1
¥y PrimaryAxisProximalPoint
¥ PrimaryAxisDistalPoint
¥y SecondaryAxisPoint
¥ Origin
y Landmarks
E Grood-Suntay Angle Sets
O/ m
il 5

Axis system name: |AxisSystem1

Rigid body: Use existing

Existing rigid body: |Use drop-lists » | RigidBodyCollectionl | Thorax v  |Axes v

Primary axis: | Positive X-axis v
Secondary axis:  Positive Y-axis v
Longitudinal axis: Positive X-axis v

Anterior axis: | Positive Z-axis

7. Save your setup and subject definition as a workspace for easy reloading in the future:

o Go to File > Save Workspace As
o Load later with File > Open Workspace
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