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The MotionMonitor xGen Hardware Guide: 
The MotionMonitor xGen Interface to Polhemus G4 Hardware 

 

Overview 

• This guide outlines the steps required to configure and collect from Polhemus G4 
devices that are connected to The MotionMonitor xGen. If using other Polhemus 
devices such as the Liberty, Patriot, Viper, or Fastrak, please see their respective 
guides. 

• This document is divided into 4 sections: 

1. Polhemus G4 System Setup 
2. Configure Polhemus G4 Hardware in The MotionMonitor xGen 
3. Calibrating a Stylus 
4. Defining Biomechanical Model within The MotionMonitor xGen 

Assumptions 

• The Polhemus G4 device is connected to The MotionMonitor xGen computer via 
USB. 

• The Polhemus drivers, G4CreateSrcCfg utilities, and the RF configuration should first 
be installed using the installation CD and instructions provided by Polhemus. 
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Section 1: Polhemus G4 System Setup  

1. Review components of Polhemus G4 Hardware:  

o Components of note include transmitter(s), wifi receiver, sensors, and G4 
hub. (See below) 

 

o The image below depicts the G4 hub connections.  

• The indicator light on the side of the hub will be solid blue when the 
hub is successfully communicating with the wifi receiver.  

• The “D-Input” port allows an event marker to be connected to the 
system, sensors can be connected to the “Sensor 1”, “Sensor 2” and 
“Sensor 3” ports. 
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2. The “G4 User Manual”, provided by Polhemus, contains step by step instructions for 
setting up and configuring your G4 transmitters.  For detailed instructions, see the 
section on Source Configuration File. 

 
3.  Determine optimal WiFi channel: 

 
o The G4 system communicates with the computer by WiFi and as such its 

sensor data is sensitive to WiFi interference in the environment. To achieve 
the best quality of data, it is recommended that the system be configured to 
run on the WiFi channel with the least amount of 3rd party traffic.  

o Run a WiFi analyzer or scanner program (which will read the signals and 
report usage and strength) to determine which WiFi channels are unused in 
your environment.  

o There are several free applications for this available on the web, 
one such program is called inSSIDerOffice, an image of which is 
shown below. You can see in the image that in this environment 
Channels 1, 2, and 3 of the 2.5 GHz band are available, while 
Channels 4-11 are in use by other WiFi devices.  

 

4. After determining the appropriate wifi channel for your system, connect the G4 
receiver to the computer. All hubs should be powered off.  

 

5. Launch the “G4 System Setup” utility. 
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6. Configure the RF Dongle: 

o Select the RF Channel Group from the radio button or dropdown menu. 

• The one hundred series corresponds to Channels 1-11 of the 2.4 GHz 
band. Using the example above, the RF Channel Group could be set to 
Group 101, 102 or 103.  

o When you have made the appropriate selections, click “Next” and then 
“Continue to Hub Setup”. 
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7. Configure the Hubs: 

o The Hubs now need to be associated with the dongle. During this process you 
can leave the G4 receiver connected to the computer.  

o Connect the first Hub to the computer via USB and turn it on. 

 

o Once the Hub is found, the utility will report the Hub Serial Number. Click 
“Join Hub 1”. 
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o If you have more than 1 hub, repeat this step. (if applicable) 

• Power down the first Hub 

• Connect the next hub and power it on.  

• Select “More Hubs” and repeat the process until all hubs have 
been configured.  

• After the last hub is configured select “Finished” 

 

8. Save Setup: 

o Once the hubs are all configured, select “Update Dongle Configuration Now” 
to send the configuration information to the dongle & prompt the user to 
also save a *.g4d file on the computer. 
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Section 2: Configure Polhemus G4 Hardware in The MotionMonitor xGen 

1. Add Polhemus Device in The MotionMonitor xGen: 
o Go to Components window > Setup Tab > Hardware.  
o In the hardware node, add the Polhemus device from the Add button in the 

parameters panel at the bottom of the Components window or by right-clicking 
the Hardware node and adding the device through the cascading drop list. 
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2. Configure Polhemus Device Parameters: 

o Click on the Polhemus device to bring up the Polhemus parameters panel. 
o Specify: 

• Name (Optional) 

• Measurement rate  

• Select 120Hz. 

• Number of sensors  

• Synchronizing event (Optional) 

• A Boolean event can be specified for performing an active 
alignment of the Polhemus data stream with synchronous 
events from other hardware data streams.  The 
Synchronizing event here must be defined from the 
Polhemus data (i.e. the stylus pen button or event marker, 
which could be defined as Polhemus1.Sensor1.Event==1, 
for instance, if the synchronizing event were connected to 
the first sensor). 

• Hardware type (G4) 

• G4 Calibration File 

• Browse to the Calibration file (*.g4c) which was setup 
through the G4 Create Source Configuration Utility.  

• Note: The Calibration file refers to the source/transmitter 
calibration and is different from the *.g4d file saved in 
Section 1. 

• Stylus to use (This stylus will be used for aligning this hardware 
device i.e. digitizing new world axes unique from the default 
transmitter coordinate system.) 

• Suspend live data (Optional) 

• The processing and display of data in a live mode uses 
computer resources, so this option allows the user to 
optimize computer resources and free up more processing 
power for data collection.  This setting is independent for 
each hardware device and once an activity has been 
recorded data from the full measurement rate will be 
accessible for analysis. 
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3. Position Transmitter and Sensors: 

o Data from the sensors can be taken from any side of the transmitter, but the 
sensors must be in the positive X hemisphere when the device is Powered on 
and activated. (See the default transmitter reference frame depicted below) 

o Polhemus G4 devices also support the use of multiple transmitters. However, the 
settings must be configured prior to activating hardware in The MotionMonitor 
xGen. These settings are configured in the G4CreateSrcCfg utility. 
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4. Activate the Device: 

o Click Activate to initialize communication between The MotionMonitor xGen and 
Polhemus hardware. 

o Optional Advanced Features: 

• Click Align to digitize a new world axes layout according to selections for 
the World Axes layout in the World Axes Setup Component. Align is used 
for hybrid configurations. 

• Click Correct Distortion to perform metal mappings. 

• Please contact your Client Support Engineer for more information 
regarding these advanced processes.  

5. Verify Device Activation and Apply Filters 

o After successfully activating the Polhemus Device, the activated sensors will 
populate under the Polhemus Hardware node 

• Expand the Polhemus Hardware node to show the activated sensors.   
o Select a Sensor to bring up the Sensor parameters panel.   
o Apply Data Repair and Filter settings (Optional) 

• These settings can be enabled or disabled here, pre or post data 
collection. 

 

6. At this point, data available directly from the Polhemus hardware can be displayed in 
graphs or used in custom equations, as depicted below.  

 

 

https://themotionmonitor.com/support/
mailto:Support@TheMotionMonitor.com?subject=Knowledge%20Base%20Article%20Questions
mailto:support@TheMotionMonitor.com


The MotionMonitorTM xGen Knowledge Base 

Page Last Updated On: 10/21/2025 

 The MotionMonitor Support Center |  Contact Us 

Section 3: Configure Stylus   

 

1. Add a Stylus: 
o A Stylus will need to be configured for digitizing the alignment of the Polhemus 

hardware device, force plates, and defining joint centers or other landmarks of 
interest for your subject.  

o Go to Components Window > Setup Tab > Hardware  
o Add the Stylus device from the Add button in the parameters panel at the 

bottom of the Components window or by right-clicking the Hardware node and 
adding the device through the cascading drop list. 
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2. Configure Stylus: 
o Click on the Stylus device to bring up the Stylus parameters panel.   
o Specify: 

• Name (Optional) 

• Rigid body sensor attached to the stylus 

• An Is-button-pressed expression (Optional) 
o Boolean value that allows for an external trigger to be used in the 

OK messages where the stylus is being used in the setup, such as 
when performing the alignment of a hardware device, aligning 
force plates or when digitizing a subject.  

• Check Rigid body is at stylus tip (If applicable) 
o Can be enabled when the origin of the Rigid body specified for the 

stylus is already located at the tip for the stylus being used, as in 
the example of Polhemus Stylus Pens.  

o Click Calibrate to set Stylus tip position and orientation.  

• The Calibrate button walks through the procedure of calculating the 
vector offset from the Rigid body origin to the stylus tip or captures the 
orientation of the stylus if the “Rigid Body is at stylus tip” is selected.  

• A tutorial video for configuring and calibrating a stylus can be found at 
https://themotionmonitor.com/support/.  
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Section 4: Define Biomechanical Model within The MotionMonitor xGen 

 

1. Set Up Subject: 
o Right-click on the Subjects header within the Components Setup tab and add a 

new subject.  
o Assign a name (Optional) and enter basic anthropometric data.  
o Confirm subject orientation for Neutral Stance and Stylus to use for digitizing. 
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2. Set Up Subject Segments: 

o Under the Subject > Segments, enable desired body segments to be tracked and 
assign rigid bodies to those segments.  Additional basic anthropometric 
information can be defined here for each segment as well.   

 

3. Define each segment’s proximal and distal joint centers: 

o The required joint centers will be automatically populated, under Subject > 
Joints, based on the selection of segments. 

o Joint centers can be defined via digitizing, marker-based expressions, linear 
regression, or functional (rotational) methods.   
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4. Calibrate Subject: 
o Once the Subject Segments and Joints definitions are completed, click the 

Subject Calibrate button to complete the model setup following the on-screen 
prompts. A warning message will be displayed for any definitions that have not 
been appropriately defined.   

 

5. Optionally, add anatomically based local coordinate systems to segments via adding an 
Axis System. Define axes based on sensor and landmark positions. 

o Select the Rigid Body axes tracking the segment and general axes layout. 
o Define points for the proximal and distal endpoints of the primary axis, a point 

along the secondary axis and a point for the Origin.   
o The default local coordinate axes generated by The MotionMonitor xGen are 

defined as having a long axes through the joint centers and A/P and M/L axes 
being orthogonal to the long axes and parallel to the world when the subject was 
standing in the neutral position.   

 

6. The subject model is now ready for data collection and computations. 

 

7. Save your setup and subject definition as a workspace for easy reloading in the future: 

o Go to File > Save Workspace As 
o Load later with File > Open Workspace 
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