The MotionMonitor xGen Hardware Guide:
The MotionMonitor xGen Interface to Polhemus Fastrak Hardware

Overview

This guide outlines the steps required to configure and collect from Polhemus
Fastrak devices connected to The MotionMonitor xGen. If using other Polhemus

devices such as the Liberty, Patriot, G4, or Viper, please see their respective guides.
e This document is divided into 3 sections:

1. Configuring Polhemus Fastrak Hardware
2. Calibrating a Stylus
3. Defining Biomechanical Model within The MotionMonitor xGen

Assumptions

The Polhemus Fastrak device is connected to The MotionMonitor xGen computer via
USB.

The Polhemus drivers and Polhemus PiMgr software are installed using the
installation CD and instructions provided by Polhemus.

e The MotionMonitor xGen software is opened.
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Section 1: Configure Polhemus Fastrak Hardware

1. Add Polhemus Device in The MotionMonitor xGen:
o Go to Components window > Setup Tab > Hardware.
o Inthe hardware node, add the Polhemus device from the Add button in the
parameters panel at the bottom of the Components window or by right-clicking
the Hardware node and adding the device through the cascading drop list.

Components H

# Setup Analysis

,l World Axes )
4t Hardware & Add > |
@ Subjects -
Mo Nhiacte 2

Live period: ‘10 ‘ sec

Playback step interval: |Use formula v  |.01 ‘ sec

' Add #~ Polhemus v
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2. Configure Polhemus Device Parameters:

o Click on the Polhemus device in the Hardware list to bring up the Polhemus

parameters pa
o Specify:
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nel.

Name (optional)

Measurement rate (choose from supported measurement rates
for the device)

Synchronizing event (Optional)

e A Boolean event can be specified for performing an active
alignment of the Polhemus data stream with synchronous
events from other hardware data streams. The
Synchronizing event here must be defined from the
Polhemus data (i.e. the stylus pen button or event marker,
which could be defined as Polhemus1.Sensorl.Event==1,
for instance, if the synchronizing event were connected to
the first sensor).

Hardware type (Fastrak)

Stylus to use (This stylus will be used for aligning this hardware
device i.e. digitizing new world axes unique from the default
transmitter coordinate system.)

Suspend live data (Optional)

e The processing and display of data in a live mode uses
computer resources, so this option allows the user to
optimize computer resources and free up more processing
power for data collection. This setting is independent for
each hardware device and once an activity has been
recorded data from the full measurement rate will be
accessible for analysis.
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Components

#F setup m Analysis

A'-., World Axes ~
v Lt Hardware

» & Polhemusl

a Subjects

% Objects v

Polhemus name: |Polhemu51

Measurement rate: | 120Hz

[] synchronizing event: when Use drop-ists <no selection=> becomes true

W Setup

Hardware type: Viper w

Stylus to use: | <none> | MNOTE: Stylus rigid body must be a Polhemus sensor
Distortion correction in use: None

: : Correct Distortion. ..

W Advanced

[ suspend live data {reduces CPU requirements by making data only available in post-processing)

(9 Activate : : Align... : : Align to Other Hardware. ..
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3. Position Transmitter and Sensors:

o Readings from the sensors can only be accurately taken from the front (positive
X) hemisphere of the transmitter. Ensure that the sensors are placed in the
transmitter’s positive X hemisphere. (See the default transmitter reference

frame depicted below)

Side View
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4. Activate the Device:

o Click Activate to initialize communication between The MotionMonitor xGen and
Polhemus hardware.
o Optional Advanced Features:

e Click Align to digitize a new world axes layout according to selections for
the World Axes layout in the World Axes Setup Component. Align is used
for hybrid configurations.

e Click Correct Distortion to perform metal mappings.

e Please contact your Client Support Engineer for more information
regarding these advanced processes.

5. Verify Device Activation and Apply Filters

o After successfully activating the Polhemus Device, the activated sensors will
populate under the Polhemus Hardware node
e Expand the Polhemus Hardware node to show the activated sensors.
o Select a Sensor to bring up the Sensor parameters panel.
o Apply Data Repair and Filter settings (Optional)
e These settings can be enabled or disabled here, pre or post data

collection.

Compenents d
F setup @B snalysis

o World Axes -~
hd Hardware

~ P Polhemusl

& Sensorl

& Subjects v
FTT mode: | Stationary Source Mode
D Repair:  Max interval: |1 sec

[] Butterwarth fiter:
[1 chebyshev filter:

[ FFT lowpass filter:

[ FFT highpass filter:  Freq: o

‘¥ Add Notch Filter Apply to All

6. At this point, data available directly from the Polhemus hardware can be displayed in
graphs or used in custom equations, as depicted below.

Type: |Scalar | Mame: Expression; |Use dropdists ~ | |Polhemus1 ~| |Sensorl | |Axes | |Pos | X | noderivative | relative to World ~ H X
Type: |Scalar | Mame: |Sensor10rientation Expression: |Use dropists ~  Polhemus1 ~| |Sensorl v | [Axes ~| O ~ Bl | |ZvX ~||Z | |noderivative | relativeto |Warld ~ Hl X
Type: |Scalar | Mame: |SensoriEventMarker Expression: |Use dropdists | Polhemus1 | |Sensor1 v | |gvent v | |nodervative | [l X

Jadd | [scalar | variable
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Section 2: Configure Stylus

1. Add a Stylus:

o A Stylus will need to be configured for digitizing the alignment of the Polhemus
hardware device, force plates, and defining joint centers or other landmarks of
interest for your subject.

o Go to Components Window > Setup Tab > Hardware

o Add the Stylus device from the Add button in the parameters panel at the
bottom of the Components window or by right-clicking the Hardware node and
adding the device through the cascading drop list.

Components n
# Setup [ Analysis

. World Axes A

@ Subjects
% Objects
X Permanent Variables
v ¥ Darmanant SerintMariahlae Y]

Live period: [10 ‘ sec
Playback step interval: 'Use formuk v | |.01 \ sec
WAdd ||/ Stylus v
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2. Configure Stylus:
o Click on the Stylus device to bring up the Stylus parameters panel.
o Specify:
e Name (Optional)
Rigid body sensor attached to the stylus
An Is-button-pressed expression (Optional)

o Boolean value that allows for an external trigger to be used in the
OK messages where the stylus is being used in the setup, such as
when performing the alignment of a hardware device, aligning
force plates or when digitizing a subject.

Check Rigid body is at stylus tip (If applicable)

o Can be enabled when the origin of the Rigid body specified for the
stylus is already located at the tip for the stylus being used, as in
the example of Polhemus Stylus Pens.

o Click Calibrate to set Stylus tip position and orientation.

e The Calibrate button walks through the procedure of calculating the
vector offset from the Rigid body origin to the stylus tip or captures the
orientation of the stylus if the “Rigid Body is at stylus tip” is selected.

e A tutorial video for configuring and calibrating a stylus can be found at
https://themotionmonitor.com/support/.

Components n
# Setup [ Analysis
~~, World Axes 3
|
v 4t Hardware |
./ Stylus1 iy

Stylus name: lStyIusl ‘

Rigid body: |Use drop-lists v | | <no selection> v
Is-button-pressed expression: |Use drop-i ~ | <no selection> v
[ Rigid body is at stylus tip

A Calibrate...

Page Last Updated On: 10/17/2025
The MotionMonitor Support Center | Contact Us



https://themotionmonitor.com/support/
mailto:Support@TheMotionMonitor.com?subject=Knowledge%20Base%20Article%20Questions
https://themotionmonitor.com/support/

Section 3: Define Biomechanical Model within The MotionMonitor xGen

1. Set Up Subject:

o Right-click on the Subjects header within the Components Setup tab and add a

new subject.

o Assign a name (Optional) and enter basic anthropometric data.

o Confirm subject orientation for Neutral Stance and Stylus to use for digitizing.

Components

# Setup Analysis

a Subjects

i a Subject1

Segments
;‘ Joints
# Muscles
@ Objects
v X Permanent Variables
X SacrumSensor
X RThighSensor
X LThighSensor

Subject name: |Subjectl

[] Assume neutral stance while supine

Neutral stance: |Arms down, thumbs forward

Body mass:  Use formula v ‘75

Body height: |Use formula v 11.75

Static fixation joint: T12/L1
Stylus to use: | <none> v

[[] Enable muscle modeling

Assume rigid bodies to be orientation-only

Maximum foot-to-GRF distance: |50

Spline interval: |10

[[] use spline fit to forces and moments

A Calibrate... | ~/ Anthropometrics...

Export Muscle Model...

& Map Muscles...

¥ Track
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2. Set Up Subject Segments:

o Under the Subject > Segments, enable desired body segments to be tracked and
assign rigid bodies to those segments. Additional basic anthropometric
information can be defined here for each segment as well.

Components n

& Setup Analysis

2 Thorax Al
v a Subjects
v @ Subject!
v/ Segments
Head
/" Thorax
Lumbar

alajoly

Sacrum 5

Rigid body: |Use existing v

Existing rigid body: |Use drop-lists v | RigidBodyCollectionl » |Thorax v | |Axes v
Longitudinal axis: 'Positive X-axis
Anterior axis:  Positive Z-axis v

Origin: |Proximal joint v

Segment-mass-to-body-mass ratio: ‘0.216

COM-offset-to-segment-length ratio: |0.82

Transverse-ROG-to-segment-length ratio: ‘ 0.3199

|
|
Longitudinal-ROG-to-segment-length ratio: l0.465 ‘
|

Anterior-ROG-to-segment-length ratio: ‘ 0.505

3. Define each segment’s proximal and distal joint centers:

o The required joint centers will be automatically populated, under Subject >
Joints, based on the selection of segments.

o Joint centers can be defined via digitizing, marker-based expressions, linear
regression, or functional (rotational) methods.

Components H
& Setup Analysis

Segments )
v ;‘ Joints
#am
# T2
o 15/51
& Left Hip
# Right Hip
;‘ Left Knee
r 4 Right Knee
# Muscles
& Objects
v X Permanent Variables
X SacrumSensor
X RThighSensor
X _LThighSensor R

ISe expression

: U ]
Position: | Use forf] pigitize with stylus |

Use functional method
Forward offset: |0/\;ca pavis formula ‘ L
| Use Bell formula
Leftward offset: l,c Use Davis formula with stylus ‘ cm
Upward offset: ‘u Use Bell formula with stylus ‘ an
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4. Calibrate Subject:

o Once the Subject Segments and Joints definitions are completed, click the
Subject Calibrate button to complete the model setup following the on-screen
prompts. A warning message will be displayed for any definitions that have not
been appropriately defined.

5. Optionally, add anatomically based local coordinate systems to segments via adding an
Axis System. Define axes based on sensor and landmark positions.

o Select the Rigid Body axes tracking the segment and general axes layout.

o Define points for the proximal and distal endpoints of the primary axis, a point
along the secondary axis and a point for the Origin.

o The default local coordinate axes generated by The MotionMonitor xGen are
defined as having a long axes through the joint centers and A/P and M/L axes
being orthogonal to the long axes and parallel to the world when the subject was
standing in the neutral position.

Components n
#F Setup @Analysis
[ / Head A
v /" Thorax
¥ Landmarks

v /‘ Axis Systems
v 2 AxisSystem1
¥y PrimaryAxisProximalPoint
¥ PrimaryAxisDistalPoint
¥y SecondaryAxisPoint
¥ Origin
y Landmarks
E Grood-Suntay Angle Sets
O/ m
il 5

Axis system name: |AxisSystem1

Rigid body: Use existing
Existing rigid body: |Use drop-lists » | RigidBodyCollectionl | Thorax v  |Axes v
Primary axis: | Positive X-axis v
Secondary axis:  Positive Y-axis v
Longitudinal axis: Positive X-axis v

Anterior axis: | Positive Z-axis

6. The subject model is now ready for data collection and computations.
7. Save your setup and subject definition as a workspace for easy reloading in the future:

o Go to File > Save Workspace As
o Load later with File > Open Workspace
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