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The MotionMonitor xGen Hardware Guide: 
The MotionMonitor xGen Interface to OptiTrack – Motive Tracker and Motive Body 

Overview 

• The MotionMonitor xGen does not collect directly from OptiTrack cameras. Instead, 
the position and orientation data of markers are streamed when they are labelled 
and assigned to Rigid Bodies (Assets), Skeletons, Active Sensors or trained Marker 
Sets. There are two OptiTrack Motive 3.0 Software; 1) Motive Tracker which has 
limited functionality and only permits the creation and streaming of markers when 
they are assigned to rigid bodies or 2) Motive Body which supports all marker types. 

 

• In either case the data are streamed via ethernet connection to the computer 
running the OptiTrack Motive 3.0 software. 

  

• This guide has 8 sections: 
1. Camera Setup & Calibration in OptiTrack Motive 3.0  
2. Creating Rigid Body Clusters in Motive 3.0 
3. Streaming Settings for Motive 3.0 
4. Activation Settings in The MotionMonitor xGen for OptiTrack 
5. Defining Rigid Body Collections within The MotionMonitor xGen 
6. Setting up a Stylus 
7. Defining and Calibrating a Biomechanical Subject Model 
8. Saving Setup 
 

This guide will focus on the creation of Rigid Bodies (Assets), please reach out to a Client 
Support Engineer if you need assistance with creating Skeletons or Marker Sets for your 
project. 

Option 1. Rigid Body Cluster (Asset): A set of at least 3 markers (4 markers preferred) fixed 
rigidly to a plate in a unique non-symmetrical configuration. Each Cluster is predefined and 
attached to a body segment or object to be tracked. 

Option 2. Marker Set: A group of markers that have been defined and trained to track 
together, this may include a combination of static and moving markers. Example opening a 
door, the frame would have stationary markers, and the door would have markers that 
move away from or toward the frame.  

Option 3. Skeleton: A series of individual markers placed on the segment end points and 
segments of interest. OptiTrack Motive have a series of predefined options, some users may 
have the ability to customize those skeletons. If a skeleton template were to be used it 
would need to be applied and updated for each participant, so it tracks correctly. 
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Assumptions 

User is using version Motive versions 3.1.3 Final or later. Please contact your Client Support 
Engineer for questions on support for specific versions of Motive software. 
Support@innsport.com or Support@TheMotionMonitor.com . 

Section1: Camera Setup & Calibration in OptiTrack Motive 3.0  
 

1. Launch OptiTrack Motive 3.0 application. 
 

2. Open the Camera Preview window  (camera icon), select each camera or all 
cameras by clicking on them in the camera window. 

 
3. Either in the Devices tab, or by right clicking on a camera, switch the Video 

Mode to MJPEG for aiming/ focusing cameras and Object Mode for marker 
tracking and low CPU usage. 

 
4. Place markers at the perimeter and in the center of the capture volume, and 

switch between the two camera modes to optimize camera settings.  
 

 
 

5. Adjust camera settings in the Properties panel: .  
 

o Set the environmental lighting and camera capture rate first, as these will 
affect the other settings. 
 

o Adjust exposure, thresholds and intensities to reduce reflections. 
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o Set gain to low medium or high depending on camera distance. 

 
a. Some camera models may also have rings on the camera lens that can 

adjust the focus and f-number. (a special tool is required to adjust 
these) 

 
b. Some camera models may have Illumination Type. Strobe is the 

default, continuous may be needed when there is infra-red 
interference from other devices.  
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o Warm-up: turn cameras on and let them warm up for at least 30 minutes. 

 
o Masking: Camera optimization from the steps above should remove/ 

minimize the number of reflections.  
a. For those reflections that cannot be removed, use “Mask” In the 

calibration panel  (Magic wand icon), masked pixels will appear 
red in the camera view. 

 
b. Frequent calibration of cameras is recommended as any 

adjustments to camera settings or camera position may impact 
marker tracking quality. Motive 3 and above include visual 
notifications when cameras are out of alignment with the 
calibration. 

 
c. Clear Masks will remove existing masks. 

 

 
 

 
6. Once masked, click continue within the calibration pane. Update the wand 

dimensions to match the camera calibration wand to be used. Click Start 
Wanding. 

 
 

o Move smoothly through the capture volume sweeping left to right, and up 
and down, turning frequently, so as not to block one specific camera for too 
long. Avoid striking the wand against objects. 
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o When an acceptable amount of data is ready for calculation, the boxes in the 
calibration pane will turn from pale green to bright green. 

 
 
7. Click Start Calculating, the system will refine the calibration and the boxes will 

turn blue.  

 
 

8. Click Continue to set the Ground Plane and determine the global coordinate 
system (place in the same place each time). 
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9.  Select the L-frame or set to Auto to be auto detected, Click Set Ground Plane 
and save the calibration files to the calibration folder. 

 
 

Section 2: Creating Rigid Body Clusters in Motive 3.0 
 

1. Create Rigid bodies with at least 3 non-linear markers. Click on the Builder Icon 

( ) in the toolbar or from the view menu.  
 
2. Click on the markers or left mouse click and drag to select a range of markers.  
 

o Click the Create from the builder pane.  
 

o Rigid bodies can be refined by moving the cluster through the space to 
improve its tracking. 

3. From the Rigid Body Settings in the Assets Pane ( ) give the Rigid Body an 
appropriate name for the segment or object it will be tracking, i.e. LThigh. 

  
o Be Consistent with naming/ capitalization for all the rigid bodies. 
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4. Adjust marker/rigid body properties in the properties panel.  
o Visualizations such as labelling can be toggled on in the perspective view by 

clicking the Visual Option Icon ( ).  
 

o Once setup, minimize the additonal visualizations to reduce CPU usage for 
optimal streaming. 

 

 

https://themotionmonitor.com/support/
mailto:Support@TheMotionMonitor.com?subject=Knowledge%20Base%20Article%20Questions


The MotionMonitorTM xGen Knowledge Base 

Page Last Updated On: 11/13/2025 

The MotionMonitor Support Center | Contact Us 

 
5. Repeat these steps 1-4 for each body segment or object Rigid Body. 
 
6. Create a Rigid Body Asset for the Stylus, this will be used in The MotionMonitor 

to digitize landmarks, define joint centers and to co-locate force plates  
 

7. Delete or Toggle off any Rigid Body Assets that are not in use, prior to activating 
in The MotionMonitor xGen. Active Assets that are not in use may cause 
unnecessary marker swapping. 

 
Section 3: Streaming Settings for Motive 3.0 

1. Update the Motive Streaming Settings by clicking on the Settings Icon ( )  and 
selecting the Streaming tab. 
 
o When Motive is on the same computer as The MotionMonitor xGen: 

a. The NatNet should be enabled. 
b. Local interface should be set to loopback. 
c. Transmission type should be multicast. 
d. Toggle on the appropriate items for the models that were defined. 

i.e., Asset Markers, Rigid Bodies, Skeletons and Trained 
Marker Set Markers. 

 
e. Define an appropriate up axis (make a note this will impact The 

MotionMonitor xGen Settings). 
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o Devices should be disabled. Force plates, EMG and other peripheral 

hardware will be connected directly into TheMotionMonitor xGen, necessary 
for guaranteed synchronicity. 

 
 

2. Leave Motive running in the background, the window may be minimized. 
 
Section 4: Activation Settings in The MotionMonitor for OptiTrack 
 

1. Open The MotionMonitor xGen. 
 

2. Go To Components Window> Setup Tab> OptiTrack1, if OptiTrack1 is not Visable 
Right Click on Hardware, Click Add and select OptiTrack. 

 

3. In the parameters panel Check the IP address, and camera measurement rate 
match the settings in Motive.  

 

o Data decimations may be applied to reduce CPU load in a live mode. If used, 
the full measurement rate will be collected and viewable in an activity. 
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4. Click Activate 

 
5. Markers and Rigid Bodies will populate under the OptiTrack1 node. Data repair 

and smoothing settings can be enabled or disabled at the marker level or rigid 
body level, pre or post data collection. 
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o It is best practice to use marker data to generate RigidBodyCollections within 

The MotionMonitor. This facilitates more functionalities to correct marker 
exchanges and filter/ remove subsections of bad marker tracking data when 
needed.  

 
Section 5: Defining Rigid Body Collections within The MotionMonitor xGen 

 
1. In the Components Tab> Setup> Right Click on Hardware and Click Add, Click 

Rigid Body Collection. One rigid body collection would be used for the stylus and 
another for the subject segments, please name appropriately. 

 
2. Irrespective of whether rigid bodies or skeletons are used to stream marker data. 

Groups of >3 markers will need to be assigned to Rigid Body Collections.  
 

o In the Animation pane left click and hold shift key to draw a box around the 
markers, right click on the yellow box click Create Rigid Body, Add to either 
the RigidBodyCollection_Stylus or RigidBodyCollection_Segments. 

o Give an appropriate name to each rigid body grouping i.e., “Stylus” “LThigh”.  
 

3. Check each rigid body in the RigidBodyCollections have the appropriately 
labelled markers. 
o  remove any markers that are named generically such as “Marker1” or 

“Marker001” without the name of the rigid body as suffix will not track 
consistently and needs to be removed. 

 
4. Use the Highlight Button  so identified markers flash.  

o If markers are missing, add markers manually by right clicking on the 
RigidBody Name and clicking add marker, use the drop-down list to map to 
OptiTrack1>Markers> and select the missing marker/s.   

 
5. Do not include markers that are to be removed for dynamic trials.  

o Once all markers have been added to the RigidBodyCollections, from the top 
level of the RigidBody Collection, with all the markers in view of the camera 
click Calibrate All, keep the markers still during this time. 
 

o Repeat for the Stylus or any other rigid body grouping. 
 

o This process can be seen in our Creating Rigid Bodies Video Tutorial available 
on our support page https://themotionmonitor.com/support/ click watch 
tutorials. 
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6. If Skeletons were used to stream marker data Step 5 will need repeating for the 

RigidBodyCollection for segments for each participant. 
 
7. The RMS threshold may be toggled on and value updated. If the RMS exceeds 

the value Rigid Body derived data will become invalid. These can be used in a live 
mode or in collected activity. 

 
8. If changes are to be made to the rigid body and marker list in OptiTrack Motive, 

always deactivate in The MotionMonitor xGen first.  
 

o Once the changes have been made and The MotinMonitor is reactivated, 
recheck all the RigidBodyCollection marker definitions are correct.  

 
Section 6: Setting up a Stylus 
 

1. In Components Window> Setup Tab Right click on Hardware to add a Stylus. 
 

2. For the Rigid body define the RigidBodyCollection > Stylus >Axes 
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3. Provide an Is-button pressed expression. This could be a hand-held event marker 
if available. This expression, when TRUE allows you to use the button press as an 
OK button during subject setup. 

 
4. Calibrate the stylus, follow the process shown in the tutorial video for Setting up 

a Stylus available on our support page https://themotionmonitor.com/support/ 
click watch tutorials. 

 
5. Use the calibrated stylus to define a World Axes and Co-Locate Force Plates, 

these tutorial videos are available on our Support page 
https://themotionmonitor.com/support/ click watch tutorials. 

 
Section 7: Defining and Calibrating a Biomechanical Subject Model 
 

1. Add a subject if there is not already one in the workspace.  
o In the components Window>Setup Tab Right clicking on Hardware click Add 

Subject. 
 

o Select the Stylus to use.  
 

o Define neutral stance, the default is hands down thumbs forward.  
 

o Maximum foot-to-GRF distance can be changed if appropriate (how far the 
foot may be from the center of pressure), this may be adjusted in a live mode 
or updated in a recorded activity. 

 

o Anthropometric Data (used for joint force and moment calculations), this 
may be adjusted in a live mode or updated in a recorded activity. 
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2. Select each segment you want to track, assign a RigidBodyCollection rigid body 

to each segment.  

 
 

 
3. Depending on the segments enabled in step 2, the number of required joint 

centers/ segment end points will automatically populate.  
o Provide definitions, select between: 1. Digitizing with stylus and identifying 

the number of points, 2. Regression methods or 3. Functional rotations. 
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4. Optional - define any custom axes and required landmarks. 
o remove any axes or landmarks that have been added by mistake and do not 

include a complete definition. 

 
 
5. The subject height and weight can be entered manually or as seen in the image 

for step 1 can be tied to a script. 
 
6. Click Calibrate Subject   
 

o follow the prompts to digitize and take a neutral stance. 
 

o Tutorial videos for Subject Setup Part 1 and advance subject setup Part 2 are 
available on our support page https://themotionmonitor.com/support/, click 
watch tutorials.  
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o A warning message will be displayed for any definitions that have not been 
appropriately defined.  

o The Calibrate Subject Icon  from the tool bar can also be selected this will 
include dialogs for script defined height and weight metrics. 

 
7. Check the segments within the animation are appropriately sized and use the 

back button to re-digitize points. 
 

8. Once the subject calibration is completed, if a segment is incorrect, or if a rigid 
body moves relative the other rigid bodies, then the Revise Calibration button 

 can be used to re-digitize a single segment. 
 
Section 8: Saving Setup 
 

1. Deactivate hardware and save the setup by Clicking File> Save Workspace As or 
using the Icon, provide an appropriate name.  
 

2. Open and load the named workspace, by going to File> Open Workspace prior to 
each data collection.  

 
3. There is an icon for Save Workspace this will save over a workspace named: 

“Current.iws” this also saves automatically when the software closes or after a 
subject calibration.  

 
o Best practice is to also have a named workspace, as changes could be made 

to the current workspace, which could subsequently cause issues to 
activation or subject calibration.   
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